Issues Sending Site-wide invitation Emails

Incident Report for SurveyMonkey Apply

Resolved

This incident has now been resolved.
Posted Oct 02, 2025 - 12:57 EDT

Investigating

We are currently investigating this issue. Customers may be running into errors when attempting to send recommendation requests.
Posted Oct 02, 2025 - 11:20 EDT
This incident affected: Main Application & Customer Sites and Customer Sites (US Hosted).